Backtrack:  
 
showing posts tagged with 'linux'
by lunarg on September 8th 2009, at 18:26
We had a bit of trouble with an Apache2 server, configured as a front-end proxy for a IIS running various different sites. The idea for this has grown because of the fact that our client had only one public IP address at the time, but had to run multiple sites. Rather than running the sites in IIS on different ports, we setup the Apache2 to proxy requests to the IIS back-end, so the sites were accessible by means of sub-urls.
E.g.:

http://myserver/mysubdomain1/ -> http://internal-ip:my-port/

For this, we used mod_proxy, and the ProxyPass and ProxyPassReverse.

Lately, our client complained of regular errors when surfing the sites. Apache2 would give HTTP error 502 (Bad gateway) on the page  ...
by lunarg on May 1st 2008, at 14:22
Currently, the Realtek R8168 driver does not work in a 2.6.24 kernel because of changes in the kernel structures. I found a patch on the Ubuntu Forums which adjusts the driver source so it can compile for a 2.6.24 kernel. The patch was written for 8.005.00, but I verified it working for 8.006.00 (latest version at time of writing). The patch is attached.

Download driver here.

Got the patch from here, but for your convenience, I've attached it to this article too.

Note that these instructions are also found on the page at Ubuntu Forums

After unpacking the driver, copy the patch in ./r8168-8.006.00/src/. Then run:

cd ./r8168-8.006.00/src/patch < r8168-8.005.00.hardy.diff.txt

Then comp  ...
by lunarg on April 17th 2008, at 12:56

If you're using NAT for networking with your VMs, you need to use port forwarding if you want to access a VM from the outside network. This is a quick and dirty howto on how to do this in linux.

Fire up a terminal, and enter these commands:

VBoxManage setextradata nvm3 "VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/HostPort" 28080
VBoxManage setextradata nvm3 "VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/GuestPort" 28080
VBoxManage setextradata nvm3 "VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/Protocol" TCP

In the sample above, I'm forwarding port 28080/tcp from the host to 28080/tcp on the guest. My VM's name is nvm3.

by lunarg on March 26th 2008, at 13:17
Had an issue on my PC at work with a corrupt reiser4 filesystem (still no clue as to why). I managed to repair the FS using RiP-Linux, but not without some data loss. After reviewing lost+found, I found most files related to some HTML cache of Konqueror, but fsck.reiser4 complained about a file that could not be recovered.
After awhile, I tried running emerge to install some new package, and there it was: a broken portage...

The error I got:

!!! Failed to complete portage imports. There are internal modules for !!! portage and failure here indicates that you have a problem with your !!! installation of portage. Please try a rescue portage located in the  !!! portage tree und  ...
by lunarg on March 6th 2008, at 10:36

Namesys, the commercial developer of the Reiser4 filesystem, still has its website down. However, the source code and development is still going on, and can be retrieved at:

http://chichkin_i.zelnet.ru/namesys/

A good thing, because it would be a shame to lose such a good filesystem...

by lunarg on March 5th 2008, at 09:29

A collegue sent me this link. It's a list of most (if not, all) LiveCDs currently available, with links to their respective websites. Additionally, they have been classified according to functionality.

http://www.livecdlist.com/

by lunarg on December 28th 2007, at 17:35
This article contains some notes about the latest 7-12 ATI linux drivers. Biggest change in versions after 8.40 (aside of the new versioning scheme), is the support for Composite and AIGLX extensions, and the supposedly improved 3D performance. Unfortunately for some, support is currently limited to newer Radeon cards only.
Installation on my X700 was not entirely straight-forward, though.

Installation took place on my laptop which has a X700 on-board, but the driver only worked properly after some tweaking of xorg.conf...

Since I'm using Gentoo, installation of the latest driver was fairly simple:

ACCEPT_KEYWORDS="~amd64" emerge -u ati-drivers

At time of writing, this would in  ...
by lunarg on November 6th 2007, at 22:57
The trouble with PSTN lines is that the CID has to be transmitted in-band, and there are more than one standard in doing this. On top of that, there are small differences between the various Telcos on the planet. And finally, to make things worse, documentation about it, is sparse and scattered at best.

The settings displayed usually go in /etc/asterisk/zapata.conf (either directly, or by inclusion).

How CID is handled is defined by the following variables:

cidsignalling: tells how the CID signalling occurs, can be bellcore (mostly US hardware), v23, or dtmf.

cidstart: specifies how the start of the CID transmission is indicated. Can be polarity (the polarity on the wire is swit  ...
by lunarg on November 5th 2007, at 16:48
Got a curious error during the merge of the latest VirtualBox ebuild for Gentoo:
it fails with a die:

Quote
kmk failed

It took a bit, but looking around the output gave some indication of a problem with one or more dependencies. Looking around the Gentoo Forum, I came across this thread, which had the proper solution.

The error, more in full, is attached.
A bit more to the top of the error (sorry, but couldn't capture the right line as the new merge was already busy), it complains about Xmd.h, and GLXext.h. In that way, the solution provided by the forum thread I mentioned earlier, makes sense. In my case, issuing the following commands did the trick:

mikuru ~ # eselect opengl set xorg-  ...
by lunarg on October 1st 2007, at 22:06
Because of my move, I had need of a media PC system, which allowed me to watch TV, record from TV, watch DVDs, listen to music and more. Buying a pc with Windows Media Center was not an option: linux has very wonderful applications and utilities to build such a sytem.
This guide is not a real how-to, but rather the steps I took to get things running, along with descriptions and solutions to caveats and problems I encountered. Since my Media PC is still in progress of being build and configured, this guide is also a work in progress. Comments on any of the steps are, of course, very welcome.

This is a work in progress...

A PC running Gentoo, with several applications to:

Watch TV, record f  ...
by lunarg on September 16th 2007, at 17:38
Realtek has a new gigabit chipset which is appearing on various motherboards, including the Asus M2A-VM board. At the time of writing (with kernel 2.6.22 being the default), this driver is not yet included in the default kernel tree.

Thanks to Realtek's wonderful support for linux, they have the driver source for various Unix/Linux flavours available for download on their website.

Download the driver from the official download site.

First, have your dependencies in order by having the following:

A sane build environment (contains gcc, make, etc.)

The kernel tree and/or headers of your current kernel.

Root access for installing and using the driver (of course).

Once all that is in orde  ...
by lunarg on September 9th 2007, at 20:59
In light of my media guide (which is still under heavy development), I did a bit of experimenting with MythTV.
The result of my experiment is pretty nifty: I now have the ability to watch TV on my laptop (without a TV tuner), as long as I have a connection to my media PC (where the tuner is). Want to know more? Read on then...

As you know (or perhaps not yet), MythTV consists of two parts: a backend server (which does all the work: managing records, accessing hardware and so on), and a frontend client (basically controls the backend server, look up recordings, watch actual TV, etc.).
These two parts communicates with each other using the IP stack. While (according to the Gentoo ebuild main  ...
by lunarg on August 28th 2007, at 12:10
Gentoo users that do regular updates, probably already ran into this issue before: Gentoo has pushed libexpat-2 to stable, effectively breaking all applications that depend upon it because of a missing library. While this is quite normal behaviour (the two versions of libexpat are not entirely compatible), it is mostly a very annoying thing, as it is not easy to find out which packages depend on it. Lucky, the Gentoo Forums provided me with a good solution.

Normally, in such a scenario, one would use revdep-rebuild to solve these issues, but, as seen on the forums, it more than occassionally results in havok on user's systems. Since I did not want to risk reinstalling my system altogether,   ...
by lunarg on August 23rd 2007, at 21:09
Had a bit of a problem with re-emerging app-arch/rpm-4.4.6-r3 after an update of libexpat: the emerge failed with a whole bunch of compiler messages.
After a quick search on Gentoo Forums, I found a post about someone who has had the same problem, and was able to solve it.

About halfway the merge, the compile failed. At the beginning of a long list, I found these error messages:

Quote
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I. -I.. -I/usr/include/beecrypt -I../lua/include -I../lua/local -I../misc -march=pentium4 -O3 -pipe -fomit-frame-pointer -fPIC -DPIC -D_GNU_SOURCE -D_REENTRANT -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts -MT rpmdav.lo -MD   ...
by lunarg on August 23rd 2007, at 20:58
Information about nvidia in Gentoo can be found here.

http://www.gentoo.org/doc/en/nvidia-guide.xml

It goes more in detail about which driver versions are suitable for which nvidia cards; quite handy, since they kicked out nvidia-legacy-drivers.

If you don't want to read the article, here's the short story about the driver version:

Geforce FX, 6, 7 and 8: use the newest driver (100.xx and up)

Geforce 3 and 4: max 96.xx

TNT, TNT2, Geforce and Geforce 2: max 71.xx

In order to properly install the correct version, it is recommended to mask the packages like so:

Add the following to /etc/portage/package.mask:

>=x11-drivers/nvidia-drivers-1.0.9700

Add the following to /etc/portage/pa  ...
by lunarg on August 17th 2007, at 15:20
This little article contains some useful tips and tricks about using tar.

When your starting point for the tar is situated at /, you may already have noticed the warning output from it:

Quote
tar: Removing leading `/' from member names

In case of an automated backup, where the tar is executed using cron, this warning quickly becomes annoying: most systems mail the output of a cron job to a specified email address (and in any normal scenario, this is configured properly to know whether a backup succeeds or fails). If each time you get a mail with only this warning (the rest of the backup was succesfully completed), one might actually lean towards suffering from a nervous breakdown (if only  ...
by lunarg on August 8th 2007, at 13:15

In absence of a decent article, here's a good resource page for performance tuning of DSPAM:

http://dspamwiki.expass.de/Performance_Tuning

by lunarg on July 29th 2007, at 15:18
An LVM structure is build as follows:At the bottom is the PV (Physical Volume), which is basically just a partition (logical or not). LVM markers need to be placed on it for LVM to see it as a usable PV.

Before actual volumes can be created, a VG (Volume Group) has to be created. A group is the second lowest structure. Only one VGs can be created on per PV, but a single VG can span multiple PVs, which makes VG a very neat thing.

The final step (before the filesystem) is the LV (Logical Volume). This is the thing that will actual hold the filesystem and data. So when mkfs-ing, it will be done on this. Several LVs can occupy one VG, but unlike VG, an LV can not span VGs (so if you were to me  ...
by lunarg on July 28th 2007, at 23:02


Has no journalling, so preferrably only used for CF and USB sticks, or for very small file systems where journalling makes things worse than better.

No indexing, so don't use for many files.

Preferred choice for external storage, because virtually all systems can read ext2/ext3 (including Windows with proper software).

Has journalling. Is perfect for all-round (server) systems, in particular root file systems and such. If there are many small files, and many files in one directory, this one is not the preferred choice because there's no specific indexing method (or none that I know of).

Has full resize support, so can be used for LVMs.

Is robust: has proven its worth.

Disaster recove  ...
by lunarg on July 25th 2007, at 00:28

Found this article to be so true...

http://www.tuxmachines.org/node/18417.

showing posts tagged with 'linux'
 
 
« December 2019»
SunMonTueWedThuFriSat
1234567
891011121314
15161718192021
22232425262728
293031    
 
Links
 
Quote
« Debating Windows vs. Linux vs. Mac is pointless: they all have their merits and flaws, and it ultimately comes to down to personal preference. »
Me