showing posts tagged with 'computer'
edited by on December 15th 2009, at 21:08
Going forward with plans for a new gaming computer, I've ordered the components. I didn't really have a specific budget in mind, other than the fact that I'm going for quality and performance, rather than selecting components based on their price.

Case: the case is an Antec Twelve Hundred gaming case. I always wanted to select a gaming case for the next one, but a nine hundred would have been just fine. The only reason why it's a twelve hundred is because of a wrong delivery a few months back, where the Antec PSU being delivered was an EC one (thus only fits in a select few cases of Antec).
The PSU is an Antec EC-850W, which is enough for now.

Motherboard: will be an Asus Rampage II Extrem  ...
edited by on December 14th 2009, at 23:26

Crap! Looks like my 8800GTX video card is broken. That's a serious bummer.

The card does some very serious funny things: as soon as going in-game, the card doesn't really freeze up, but has some sort of memory corruption problem, which remains throughout reboots.

Very coincidentally, I just ordered new hardware for my new gaming computer. The only thing not being replaced was the video card, because I thought it would be better to just wait a while until the next generation of cards from nVidia were available.
Apparently, Fate has decided otherwise.

edited by on October 30th 2009, at 13:26
Since Office 2007 (and Vista), TWAIN has been kicked out in favour of WIA. As a result, it is no longer possible to use your favourite and robust TWAIN based scanner with Office 2007.
Most scanners come with the necessary software, and thus, you can circumvent the issue by using their software. However, there are various scanners - notably, office network scanners, like those on copiers, do not have such a tool. They have their driver's internal system which is callable in other software (like Office-applications). In the event that the driver is only supporting TWAIN interface for image acquisition, they do not show up in Vista's scanner list, and therefore, they cannot be used by Office 20  ...
edited by on October 28th 2009, at 15:50
Ran into an issue where I could not unlock files that were copied from a network location to local disk. The files were marked as being locked, but I was unable to unlock them (through Finder), even though I had all proper rights. Additionally, chmod as root (= user with the highest privileges) did not work either.

The solution to my issue was to manually override the locked flag of those files, from within a Terminal.

sudo chflags -R nouchg my-problem-file-or-dir

Additionally, I found that it sometimes is easier to completely reset/clear an ACL, and start over, rather than trying to fix the ACL. This can also be done in a Terminal.

sudo chmod -R -N my-problem-file-or-dir

This completel  ...
edited by on October 5th 2009, at 21:49
When running a Windows XP or 2003 in VirtualBox, under certain circumstances, the guest may generate a BSOD when booting. The message of the BSOD is a:


It is accompagnied by a referral to processr.sys, intelppm.sys or p3.sys, depending on the CPU used to install the machine.

The reason for this BSOD is a problem with these drivers, trying to perform an unsupported operation inside the virtual machine (like updating microcode or changing the power state of the CPU).
The issue usually surfaces when the guest machine is moved to a different system with different CPU time.

To resolve the issue, the processor drivers have to be disabled. T  ...
edited by on September 24th 2009, at 18:02

Found this article, showing you how to lock down Firefox.

This is quite useful when deploying Firefox on, for instance, a Terminal Server.

edited by on September 8th 2009, at 18:26
We had a bit of trouble with an Apache2 server, configured as a front-end proxy for a IIS running various different sites. The idea for this has grown because of the fact that our client had only one public IP address at the time, but had to run multiple sites. Rather than running the sites in IIS on different ports, we setup the Apache2 to proxy requests to the IIS back-end, so the sites were accessible by means of sub-urls.

http://myserver/mysubdomain1/ -> http://internal-ip:my-port/

For this, we used mod_proxy, and the ProxyPass and ProxyPassReverse.

Lately, our client complained of regular errors when surfing the sites. Apache2 would give HTTP error 502 (Bad gateway) on the page  ...
edited by on September 7th 2009, at 20:34
Did you know that since version 10.4, Mac OSX has a VNC server built in? It was originally implemented to have remote control and management. Since 10.5 (where Apple Remote Desktop was implemented for remote managing), they have renamed it to screen sharing, but the principal remains the same.

To enable it, follow the instructions below.

The following guidelines are for Mac OSX 10.6, but they are roughly the same for other versions.

Open System Preferences.

Find the icon that says Sharing.

In the list of services at the left, select and enable Screen Sharing by ticking its checkbox.

By default, no authentication is set, and so, you cannot yet use VNC. To set the password, click o  ...
edited by on August 28th 2009, at 11:51

If you're looking for a better defrag, check out UltraDefrag:

Some highlights of the software (as told on their site):

  • Boot Time Defragmentation allows for defragmenting upon boot (like an antivirus), useful for system files, like the registry, the pagefile, ...
  • Option to shutdown the computer once defrag has completed.
  • Aside of defragging, there's also compacting, which rearranges data to the beginning of the disk, increasing performance and stability;
  • Single file and folder defragmentation, in case you only need to defrag an application or files that have just been placed on disk.
edited by on May 17th 2009, at 12:41

During the course of the lifetime of a Windows Installation, you're bound to stack up on one or more devices that no longer exist. Additionally, some device (existing or not) with an attitude, could very well make your life a living hell.
Luckily, there's a solution, with this cool software:

edited by on April 29th 2009, at 19:48
Acquired a new appliance from Mini-ITX, which is to replace my current WRT54GL (flashed with OpenWRT White Russian).

Specs of the thing are:

Durable industry-standards housing, including a mount bracket for 2.5" disks

2x 1000 Ethernet, 4x 10/100 Ethernet, 2x USB 2.0, VGA, PS/2

VIA chipset with a VIA Eden 1ghz CPU, 1x DDR2 slot, 1x CF slot

1x IDE 2.5" port, 1x SATA port

I've equipped it with 512 MB RAM (standard was 256 MB), and a 4 GB CF card, and installed Debian Lenny i686 on it.

Because of the fact it's CF, I've tweaked the initramfs image of Debian so it uses overlaying for /var and /etc (using aufs) in RAMDISK, and mounting / as read-only. This allows me to save the f  ...
edited by on September 18th 2008, at 16:35
When you're using a Belgian keyboard (or another) on a Windows 2003 Terminal Server, you might have the same problem we had: characters that are formed with a combination of AltGr and other characters (e.g. the @ sign) don't work as they should.

There are two things you can do to work around this problem.

Instead of using AltGr, try using CTRL+ALT and the key you want. This circumvents the problem, but may not be what you want.

You can change the application of Windows key combinations. Rather than applying them to the TS, you can change it so it applies only to the local computer.
This disables the Alt+Tab and Windows key in the TS session, which is probably also not really what you want  ...
edited by on May 1st 2008, at 14:22
Currently, the Realtek R8168 driver does not work in a 2.6.24 kernel because of changes in the kernel structures. I found a patch on the Ubuntu Forums which adjusts the driver source so it can compile for a 2.6.24 kernel. The patch was written for 8.005.00, but I verified it working for 8.006.00 (latest version at time of writing). The patch is attached.

Download driver here.

Got the patch from here, but for your convenience, I've attached it to this article too.

Note that these instructions are also found on the page at Ubuntu Forums

After unpacking the driver, copy the patch in ./r8168-8.006.00/src/. Then run:

cd ./r8168-8.006.00/src/patch < r8168-8.005.00.hardy.diff.txt

Then comp  ...
edited by on April 22nd 2008, at 22:40

What would an OS says or think when copying files - let's say, about 100MB of MP3 - to an SD card?


What's an SD card?

Linux (bash)


Windows XP

Alright. Wait around a bit, and it'll be done. Don't ask me when, because I'm terrible at guessing.

Windows Vista

What? Me? Do you have any idea what you're asking of me? It requires careful planning: first see whether it all fits on your card, then calculating the time, and even then, I'm not sure if I'll do it. Maybe you should check back tomorrow; maybe I've gotten around to it by then, just maybe...

edited by on April 17th 2008, at 12:56

If you're using NAT for networking with your VMs, you need to use port forwarding if you want to access a VM from the outside network. This is a quick and dirty howto on how to do this in linux.

Fire up a terminal, and enter these commands:

VBoxManage setextradata nvm3 "VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/HostPort" 28080
VBoxManage setextradata nvm3 "VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/GuestPort" 28080
VBoxManage setextradata nvm3 "VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/Protocol" TCP

In the sample above, I'm forwarding port 28080/tcp from the host to 28080/tcp on the guest. My VM's name is nvm3.

edited by on April 8th 2008, at 09:18

Got a link to this article about best practices on keeping your inbox as empty as possible. Very useful for those that get a lot of mail at work:

Additional comments:

edited by on March 26th 2008, at 13:17
Had an issue on my PC at work with a corrupt reiser4 filesystem (still no clue as to why). I managed to repair the FS using RiP-Linux, but not without some data loss. After reviewing lost+found, I found most files related to some HTML cache of Konqueror, but fsck.reiser4 complained about a file that could not be recovered.
After awhile, I tried running emerge to install some new package, and there it was: a broken portage...

The error I got:

!!! Failed to complete portage imports. There are internal modules for !!! portage and failure here indicates that you have a problem with your !!! installation of portage. Please try a rescue portage located in the  !!! portage tree und  ...
edited by on March 13th 2008, at 11:30
When printing from a Vista computer to a shared computer, you notice the following:

Printing takes a long time to begin.

Opening the Print dialog (e.g. in Word) takes a long time.

Selecting printers in the Print dialog is slow.

The real reason is unknown, but Vista seems to have a problem with excessive querying of the printer. Along with the usual slowdowns of network traffic, this causes serious slowdowns.

The trick is to have Vista believe it is dealing with a local printer, rather than a shared printer. This is done by specifying a Local printer port, pointing to the share, then configure the printer on that port:

Open Printers, and then Server Properties.

Select the Ports tab, an  ...
edited by on March 6th 2008, at 10:36

Namesys, the commercial developer of the Reiser4 filesystem, still has its website down. However, the source code and development is still going on, and can be retrieved at:

A good thing, because it would be a shame to lose such a good filesystem...

edited by on March 5th 2008, at 09:29

A collegue sent me this link. It's a list of most (if not, all) LiveCDs currently available, with links to their respective websites. Additionally, they have been classified according to functionality.

showing posts tagged with 'computer'
« February 2024»
« Debating Windows vs. Linux vs. Mac is pointless: they all have their merits and flaws, and it ultimately comes to down to personal preference. »